Setingan Mikrotik dengan ClearOS Sebagai Standalone Server

Tulisan ini dibuat untuk dokumentasi setting jaringan CCNet.

              Modem------MIKROTIK -----SWITCH   ----- CLIENT
Topologi                              |
                               PROXY ClearOS  

Saya tidak membahas Instalasi ClearOS disini, mungkin lain kesempatan akan saya buatkan tulisannya.
Asumsi : ClearOS sudah jalan dan proxy sudah bekerja secara normal (tidak ada masalah)


IP ClearOS 192.168.2.2 dengan submask 255.255.255.252 Gateway 192.168.2.1

Setting IP Address
/ip address
add address=192.168.11.13/24 disabled=no interface=local network=192.168.11.0
add address=192.168.2.1/30 disabled=no interface=COS network=192.168.2.0
add address=192.168.1.2/24 disabled=no interface=wan network=192.168.1.0

Setting JAM MIKROTIK
/system clock
set time-zone-name=Asia/Jakarta
/system clock manual
set dst-delta=+00:00 dst-end="jan/01/1970 00:00:00" dst-start=\
    "jan/01/1970 00:00:00" time-zone=+07:00

Setting DNS
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 servers=202.134.1.10,8.8.4.4

IP Firewall Filter
/ip firewall filter
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=drop chain=input comment="Drop Invalid Connection" \
    connection-state=invalid disabled=no
add action=drop chain=input disabled=no dst-port=21,22,23 in-interface=wan \
    protocol=tcp
add action=accept chain=forward comment="Forwarding to Proxy" disabled=no \
    in-interface=COS protocol=tcp
add action=accept chain=forward disabled=no in-interface=COS protocol=udp

IP FIREWALL NAT
/ip firewall nat
add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
add action=masquerade chain=srcnat comment="LOCAL NAT MASQUERADE" disabled=no \
    out-interface=wan
add action=dst-nat chain=dstnat comment="REDIRECT KE PROXY" disabled=no \
    dst-address=!192.168.0.0/16 dst-port=80 in-interface=local protocol=tcp \
    src-address=192.168.11.0/24 to-addresses=192.168.2.2 to-ports=3128

IP FIREWALL MANGLE
/ip firewall mangle
add action=mark-packet chain=postrouting comment="SQUID PROXY HIT" disabled=\
    no dscp=12 new-packet-mark="PROXY HIT" passthrough=no

sekarang liat ClearOS melalui Webconfig   
masuk ke direktori /etc/firewall-scripts


Cari tulisan

SQUID_TRANSPARENT="off"
SQUID_FILTER_PORT=""

GANTI
SQUID_TRANSPARENT="0n"
SQUID_FILTER_PORT=""


dan pastikan juga di Squid.conf  sudah ada

http_port 3128 transparent

Saat nya mencoba proxy jalan apa ngga http://www.lagado.com/proxy-test
jika jalan muncul IP dan keterangan proxy nya


Catatan :
  1. Sebaiknya update module dan regristrasi Clearos.
  2. Periksa saat pemasangan kabel jaringan.
  3. Sebelum mulai mengoprek ketahap berikutnya sebaiknya tes ping masing masing interface dulu.
  4. Jika masih belum sukses, review kembali langkah2 diatas.
  5. Jangan menyerah dan jangan takut salah, terus berusaha pasti bisa.

SHARE

About Cozy Corner Net